ID Verification Delays
Incident Report for GDAX
Resolved
This incident has been resolved.
Posted 5 months ago. Jan 17, 2018 - 10:43 PST
Monitoring
ID document verification is delayed for some customers due to high traffic. We are working on reducing delays.
Posted 6 months ago. Dec 15, 2017 - 12:01 PST